Cisco 1601R with IOS 12.0.22 and Nat
Layout
Note:
- The 1601R only has one ethernet port, so I use "interface loopback0"
to overload it with two IP addresses (one public: 193.0.0.1, and one private:
10.0.0.1). In addition to routing, the 1601R performs NAT between networks
10.0.1.0/24 and 193.0.0.0/24
- The two Cisco's are connected with a cross-over cable acting as DTE-DCE
- The NAT address pool runs from 193.0.0.2 through 193.0.0.254
Configuration files
2501
- version 12.0
- service timestamps debug uptime
- service timestamps log uptime
- no service password-encryption
-
- hostname 2500
-
- enable secret 5 $1c/Mh$hZ0o6FkS7xYH2ak7LOfAS1
- enable password cisco
- username toto password 0 cisco
-
- ip subnet-zero
- no ip domain-lookup
-
- interface Ethernet0
- ip address 195.0.0.1 255.255.255.0
- no ip directed-broadcast
-
- interface Ethernet1
- no ip address
- no ip directed-broadcast
- shutdown
-
- interface Serial0
- ip address 194.0.0.1 255.255.255.0
- no ip directed-broadcast
- encapsulation ppp
- no fair-queue
-
- interface Serial1
- no ip address
- no ip directed-broadcast
- shutdown
-
- no ip classless
- ip route 193.0.0.0 255.255.255.0 194.0.0.2
-
- line con 0
- transport input none
- line aux 0
- password cisco
- login
- modem InOut
- transport input all
- flowcontrol hardware
- line vty 0 4
- exec-timeout 0 0
- password cisco
- login
-
- end
1601R
- version 12.0
- service timestamps debug uptime
- service timestamps log uptime
- no service password-encryption
-
- hostname 1601R
-
- enable password cisco
-
- ip subnet-zero
- no ip domain-lookup
-
- interface Loopback0
- ip address 193.0.0.1 255.255.255.0
- no ip directed-broadcast
- ip nat outside
-
- interface Ethernet0
- ip address 10.0.1.1 255.255.255.0
- no ip directed-broadcast
- ip nat inside
-
- interface Serial0
- ip address 194.0.0.2 255.255.255.0
- no ip directed-broadcast
- ip nat outside
- encapsulation ppp
- no ip mroute-cache
- clockrate 64000
-
- ip nat pool ip-pool 193.0.0.2 193.0.0.254 netmask
255.255.255.0
- ip nat inside source list 1 pool ip-pool
- ip classless
- ip route 195.0.0.0 255.255.255.0 194.0.0.1
-
- line con 0
- transport input none
- line vty 0 4
- login
-
- end
Issues
From the 10.0.1.2 host, I can't ping any address in the 195.0.0.0/24 network
(either router or host.) debug ip packet displays a single line:
IP: s=10.0.1.2 (Ethernet0), d=195.0.0.2 (Serial0), g=194.0.0.1, len 60, forwardq
FYI, the 195.0.0.2 can ping
Note: On the other side of the network, host 195.0.0.2 can ping the 1601R's
public ethernet address 193.0.0.1 just fine.
How to avoid using a small network to connect the two routers (ie. get rid
of the 194.0.0.0/24 network)
I was told about using ip address unnumbered, and simply use one of the IP
addresses used in the public networks on each side. Can this be done with the
1601R? Are there any drawbacks?