OpenStreetMap pour les cyclistes

Introduction

Tâches fréquentes

Identifier un node/way dans Id

Passer en mode édition, sélectionner l'élément, et taper CTRL+i

Tagger une rue avec un DSC

Récupérer tous les M12 via OverpassTurbo

[out:json][timeout:25];
(
  relation["restriction:bicycle"="give_way"];
);
out body;
>;
out skel qt;

Ajouter un panneau "Céder-le-passage-au-feu"

Son nom officiel est M12.

La manip est plus simple avec l'éditeur dédié JOSM écrit en Java, mais peut normalement être effectuée directement dans un navigateur via l'éditeur en ligne Id.

Directement via un navigateur (Id)

  1. Si nécessaire, scinder les ways qui passent par le feu rouge afin de pouvoir ensuite les sélectionner individuellement
  2. Sélectionner le feu, et y ajouter une relation définie par ces tags:

    type=restriction
    restriction:bicycle=give_way

    role=via
  3. Donner un nom à cette relation afin de pouvoir facilement la retrouver dans les étapes suivantes
  4. IMPORTANT Enregistrer la modification, afin de rendre la relation visible dans les étapes suivantes
  5. Sélectionner la way par laquelle arrive le cycliste, ajouter la relation de restriction précédement créée, et définir son rôle comme "from"
  6. Sélectionner la way vers laquelle le cycliste pourra se diriger après le feu, ajouter la relation de restriction précédement créée, et définit son rôle comme "to"
  7. Enregister la modification.

Avec JOSM

https://josm.openstreetmap.de/wiki/Introduction

  1. Zoomer sur la zone
  2. File > Download from OSM pour télécharger la zone
  3. Cliquer sur le feu tricolore
  4. À droite, dans la section Relations, clique sur le bouton + pour ajouter une nouvelle relation
  5. Commencer par ajouter deux tags (key = value): type=restriction, et restriction:bicycle=give_way (!!!! No autocompletion!!!!)
  6. Dans la partie en bas à droite, sélectionner le feu tricolore, et cliquer sur le premier bouton "Add all objects selected in the current dataset before the first member"
  7. Si nécessaire, déplacer la boîte de dialogue "Edit new relation", et dans la carte, cliquer sur la way qui doit jouer le rôle de From: La sélectionner dans la liste Selection, puis cliquer sur le premier bouton "Add all objects selected in the current dataset before the first member"
  8. Faire de même pour la way qui doit jouer le rôle de To.
  9. Envoyer les modifications via File > Upload data.
  10. Si cette modification est effectuée en se basant sur une observation du terrain, indiquer "Survey" pour la questoin "Specify the data source for the changes".

Un résumé des étapes:

 

 

 

Une fois JOSM lancé, zoomer sur la zone où se trouve le croisement où se trouve le ou les CLPAF, puis télécharger cette zone via File > Download from OSM

- démarrer JOSM

- copier l'url de la relation https://www.openstreetmap.org/relation/6376715#map=17/48.81533/2.29865

- dans JOSM télécharger un objet (CTRL+MAJ+O)

- cliquer sur Télécharger un objet, les 3 options étant cochées (il propose r6376715 c'est à dire la relation en question).

- dans la relation supprimer ce qui est inutile.

- créer les deux autres relations.

N. B. : je crois que tu peux copier la relation et la coller dans un nouveau calque (deux fois) et faire le ménage.

Ne la colle pas (comme je l'ai fait par erreur) dans un même calque car alors c'est une copie profonde et tu vas galérer.

---

> Ok, donc si un croisement possède plusieurs panneaux M12, il faut ajouter un relation "via" pour chaque panneau?

Exact. [Dit autrement : à chaque manoeuvre possible sur le terrain sa relation dédiée dans OSM.]

Trois réponses à la question précédente :

- en cliquant sur le lien JNLP, l'installation de JOSM et de Java doit être automatique, donc à la portée du cycliste non informaticien

- si tu fais trois fois la manip avec ID ça marche.

Car tu veux ajouter trois panneaux sur trois feux différents (symbolisés par un bloc de feu au centre).

Pour les restrictions tu dis d'où tu viens (et tu ne viens que d'un endroit) et où tu vas (tu vas à un seul endroit) et par où tu passes (le feu).

Avec JOSM : tu sélectionnes le chemin d’où tu arrives,, celui où tu vas et le feu.

Préréglages > Relations > Interdiction de tourner.

Il suffit d'ajouter la restriction:bicycle=give_way

- un cycliste non informaticien veut une carte à la première personne et faire un clisser coller d'un panneau M12. Moins de risque d'erreur.

Un gros avantage de JOSM c'est que tu fais ton marché des greffons pour avoir ce qui t'intéresse.

---

 

Pour les M12a et M12b, c'est par des relations qu'on les intègre (ce qui est assez lourd), exemple: http://www.openstreetmap.org/relation/5453716

Si tu n'es pas habitué aux relations, c'est sûr que c'est loin d'être évident à comprendre. As-tu essayé de regarder avec JOSM ?

http://gis.19327.n8.nabble.com/Bonne-methode-pour-ajouter-un-feu-rouge-td5876628.html

http://gis.19327.n8.nabble.com/Nouvel-outil-pour-le-controle-des-interdictions-de-tourner-td5791466.html

http://gis.19327.n8.nabble.com/Paris-generalisation-du-cedez-le-passage-cycliste-td5849462.html

Un way est composé de nodes reliés entre eux. Pour placer ton feu rouge il faut que tu insères un node sur l'avenue (sélectionne le way, un petit + apparait à côté de ton curseur quand tu survoles le way entre deux nodes, fais un cliquez glissez pour insérer un node et le placer) auquel tu ajoutes les attributs qui vont bien (highway=traffic_signals ...)

Utiliser JOSM sans l'installer : Tu peux lancer la version "jnlp" de JOSM, directement depuis le site officiel (nécessite d'avoir Java installé sur sa machine). https://josm.openstreetmap.de/

Alternative à JOSM : QGis

Example tourne-à-droite à Malakoff : https://www.openstreetmap.org/relation/6376715#map=19/48.81538/2.29892

Expurger la carte des campings d'Archie's Campings

Ici, on suppose que l'utilisateur souhaite effectuer un voyage à vélo et ne garder des fichiers Archie's Campings que les campings à proximité d'un itinéraire. Il y aura donc deux fichiers GPX.

Infos

QuickOSM = plugin QGIS

Format Shapefile = format très couramment utilisé avec les logiciels SIG

Avec JOSM 10327

https://fr.wikipedia.org/wiki/JOSM

  1. Avec File > Open, ouvrir le fichier GPX qui contient le parcours vélo. Si la trace est difficile à voir, dans la fenêtre Layers, faire un clic-droit sur la trace, sélectionner "Custom track drawing" et "Customise colour". Pour afficher une carte en fond d'écran, cliquer dans le menu Imagery. Pour déplacer la carte, maintenir appuyé le bouton droit de la souris
  2. Avec File > Open, ouvrir le fichier GPX qui contient les campings. Il est ajouté dans la fenêtre Layers sous le nom "Markers from…"
  3. Dans la fenêtre Layers, sélectionner ce nouvel item, faire un clic-droit et sélectionner "Convert to data layer". Ignorer le message d'avertissement
  4. À ce stade, les campings sont difficiles à voir : dans la fenêtre Layers, masquer la carte en cliquant sur l'icône en forme d'œil à gauche de la carte
  5. Dans le menu principal, cliquer sur File > New Layer
  6. Dans la fenêtre Layers, faire un clic-droit sur l'item "Converted from: Markers from…", et sélectionner Activate
  7. Dans la barre d'outils, sélectionner l'outil Lasso afin de sélectionner les campings le long de la trace
  8. Dans le menu Edit, choisir "Merge Selection", et cliquer sur OK. Dans la fenêtre d'avertissement, cliquer sur Continue
  9. Dans la fenêtre Layers, faire un clic-droit sur l'item "Data Layer 1", cliquer sur Activate
  10. Faire un nouveau clic-droit sur cet item, et sélectionner "Export to gpx"
  11. Copier le fichier dans le GPS et vérifier que la trace + campings apparaissent comme prévu.

Pour rendre les waypoints plus visibles sur la carte:

Avec QGIS

En date de mai 2017, le site ne permet au mieux que de récupérer un fichier par pays, ce qui dans le cas de la France par exemple, donne un fichier GPX de plus de 9.000 waypoints.

Avec l'application QGIS, voici comment expurger la liste en ne gardant que les campings à quelques kilomètres d'un itinéraire en GPX:

  1. Install and launch QGIS Desktop (with or without GRASS). It's a heavy application, so it may take a while to load
  2. Install the POI Exporter plug-in
  3. Vector > GPS > GPS Tools > Browse: Choose POIs GPX file (Unselect all and keep Waypoints; If POIs are also available as polygons, you'll need to turn those into waypoints)
  4. Vector > GPS > GPS Tools > Browse: Choose track GPX file (Unselect all and keep Tracks; If routes are also available, you'll have to merge the two into a single item after converting them into shapefiles)
  5. Right-click on waypoints item > Save as > ESRI Shapefile, use original name (eg. if waypoints.gpx > Choose "waypoints")
  6. Remove original item (waypoints)
  7. Right-click on track item > Save as > ESRI Shapefile, use original name (eg. if tracks.gpx > Choose "tracks")
  8. Remove original item (tracks)

    At this point, you should only have two items, the shapefiles made from the original GPX items
     
  9. Vector > Geoprocessing Tools > Fixed distance buffer: In the "Input layer", choose the tracks item; The Distance parameter depends on the layer CRS units (Coordinate Reference System), so you'll have to experiment or google for the right way to fill this parameter (eg. in WGS84, try 0,05), or convert the layer into a meter-based CRS
  10. Vector > Geoprocessing Tools > Intersection: Select the waypoints item as source, Intersects, Reference features = Buffer > Apply
  11. Click on the button in the lower right-hand button ("Create layer with list of items"): You should have the waypoints item filtered in this new layer
  12. To save the layer as a GPX file, select it in the list, and click on the POI Exporter icon in the toolbar

Notes

Avec un script Python

Trouver comment manipuler des fichiers GPX, et calculer la distance les points des campings et les points qui constituent une trace.

Import libraries

- Shapely: http://toblerity.org/shapely/manual.html

- Geopandas: http://geopandas.org ; "Geometric operations are performed by shapely"

GPX Editor

Testing

1. Mettre à jour lien sur Sourceforge "GPX Editor Web Site" sur Sourceforge. https://sourceforge.net/projects/gpxeditor/

http://www.knackes.com/blog/index.php?2008/11/20/193-gpx-editor-1070

Manque:

3. A quoi sert Edit > Merge all tracks? Dans quel cas peut-on l'utiliser sans que ça donne n'importe quoi?

Edit > Rename Tracks: "Débordement d'entier." Comment utiliser cette fonction?

Impossible de renommer segment: Difficile de déplacer un segment d'une track dans une autre puisqu'elles s'appellent toutes "Track Segment #1". De même difficile, difficile de modifier leur ordre dans une track par drag 'n drop (pas de changement de forme de curseur : au dessus ou en dessous de l'item destination?).

Pourquoi pas de fonction "Merge All Segments into One Track"?

Sélectionner plusieurs folders (tracks) > Delete : Pas supprimées. F5 pour rafraîchir : sans résultat. On doit supprimer chaque folder/track manuellement.

Si on enregistre sous un nom de fichier existant, pas de confirmation avant écrasement.

GpsPrune

"GpsPrune is a [Java] program for loading, displaying and editing data from GPS receivers."

The User guide is a non-free PDF/ebook, but there's a howto.

Point - any point. It can contain any number of fields, but must have at least latitude and longitude.

Waypoint - a special type of point, which has a name. These generally appear in any order, often alphabetical. They are shown in Prune as a black square, and the names are listed on the left panel. Waypoints are not used for distance calculations by Prune, apart from in the "View -> Distances" dialog. When they're exported to Google Earth, each waypoint appears as a yellow pushpin with a name.

Track point - a point which is part of a track, which means that it doesn't have a name. The order in which track points appear is important, because the order defines the track. Track points are shown in Prune as blue squares, and points within the same track segment are joined together with a blue line. When they're exported to Google Earth, the line appears as a red line but the individual points aren't shown. Track points may have altitudes and may have timestamps, and may have other fields too.

Route point - some programs also distinguish between route points and waypoints, but a route is just an ordered list of waypoints, so Prune doesn't treat route points separately.

Si les traces se suivent, permet de fusionner des fichiers GPX en un seul, voire fusionner les segments en un seul.

GpsTrackEditor

Version la plus récente : 1.15 beta (build 141) de 2015.

Chaque élément dans la liste Tracks correspond à une section "<trkseg>" dans le fichier, et chaque élément dans la liste Points correspond à un "<trkpt>" dans le fichier.

Pour fusionner plusieurs <trk> en un seul, les sélectionner tous puis cliquer sur Merge.

Pour fusionner tous les <trkseg> en un seul, les sélectionner tous puis choisir Restructuring > Join.

Pour scinder un trkseg en deux, sélectionner un point, faire un clic-droit puis sélectionner Restructuring > Add break.

Note : même avec des traces qui se suivent, l'option Merge ne respecte l'ordre. Et la fonction Join dit Only consecutive track segments can be joined.". Essayer avec GpsPrune.

Quand on ouvre plusieurs fichiers GPX et que les parcours sont en sens inverse, il suffit de renommer les fichiers dans le bon ordre avant de les importer dans GTE.

GTE ne permet pas de fusionner plusieurs fichiers GPX en un seul : utiliser un batch avec GpsBabel.

Q&R

Impossible copier ou drag 'n dropper un segment d'un fichier dans un autre?

Seule solution, Google My Maps? GMM limite un fichier GPX à 5MB, mais le même fichier en KML est accepté.

Si bizarreries type spaghettis, ouvrir fichier dans GTE et ajouter timestamps au préalable. Si toujours NOK, vérifier que, dans le fichier, les segments se suivent dans chaque track, et que les tracks se suivent.

Impossible copier coordonnées d'un point dans presse-papier?

Comment annuler une restructuration (Track > Restructure)?

Impossible déplacer trace dans l'arborescence?

Pas possible passer de la carte à l'arborescence par CTRL+TAB?

Dans la liste Points, impossible sélectionner partie avec Shift pour supprimer plusieurs points?

Work-around: Maintenir touche Del appuyée, en faisant attention à ne pas dépasser (pas de CTRL-Z pour annuler : pour restorer les points supprimés par erreur, pas de raccourci clavier : il faut faire un clic droit sur chaque point puis Restore)

Note: Del = temporaire; Shift+Del = définitif

Après avoir sélectionné plusieurs fichiers, quelle différence entre Merge et Join? Que se passe-t-il si on clique sur Save As?

Si on sélectionner plusieurs segments dans une trace: Merge crée une nouvelle trace, avec les segments toujours distincts; Restructuring > Join crée une nouvelle trace où les segments sont effectivement fusionnés en un seul. Parfois, la fonction Join génère des effets étranges sur la carte (pas de fonction Undo?)

Merge = Save As = n'importe quoi (plat de spaghettis)

Join: "Only consecutive track segments can be joined."

"Adjust Time: Some points of a track do not have valid timestamps."

Cela se produit quand au moins un des <trkpt> ne possède pas de timestamp.

Pas de Undo/CTRL+Z?

Dans Tracks, signification triangle vs. ? vs. ??

Comment sélectionner une partie d'une track, et supprimer le reste ou le copier dans un autre fichier? Pas possible dessiner rectangle avec souris

TO CHECK

OSM ajouter un M12 via Id https://www.youtube.com/watch?v=TQyPGEQ0A2k

Que faire si une des deux ways est longue? Faut-il couper juste avant/après pour que la relation concerne juste le bon segment?

Josm : comment fermer carte une fois données modifiées et enregistrées? File > Delete Layer

TEMP

OpenCycleMap

Cycle.travel

Maps.me

 

Ajouter des infos dans OSM

linéaire cyclable

Impasse ouverte

Parking vélo

Dénivelé dans OSM?

M12

Ressources