Quick Guide to Sony's Vegas Movie Studio

Introduction

"Sony Vegas Movie Studio is a consumer-based nonlinear video editing software designed for the PC. It is a scaled-down version of Sony Vegas Pro. [...] Since Version 6, there have been two versions: Vegas Movie Studio+DVD and Vegas Movie Studio+DVD Platinum Edition, which adds AVCHD/HDV and 5.1 Surround capabilities."

Note: VMS cannot open a MOD file coded in MPEG-PS (MPEG video + AC-3 audio).

Commercial alternative to MS' free Movie Studio

Better get a camcorder that saves data in raw format rather than compressed.

Basic Tasks

Adding files to a project

Project > Import Media. Check the status bar: On big files, it'll take several minutes for Vegas to read and import it in the project.

"You have opened a media file which contains multiple channels of audio.  Would you like to set the current project to 5.1 surround mode? Yes/No": Front, Center, LFE, Rear

Replacing part of a video with still pictures

This is used when you need to replace some parts of a video with pictures. A typical example would be if you shot a conference with a single camera where the speaker showed some PowerPoint slides through a projector so you'd like to edit the video later to replace some parts of the video stream with the slides that you shot live.

  1. Project > Import Media. Check the status bar: On big files, it'll take several minutes for Vegas to read and import it in the project.
  2. Using SHIFT and the right arrow, select the part of the video track where the still picture will be pasted; This part is the Loop Region and is displayed with two yellow triangles on either side
  3. In the Preview part of the screen, make sure it's using the same definition as the video track; Navigate to where the video shows the part you want to save a still picture, and save into a JPEG or PNG file through the "Copy snapshot to clipboard" icon in the Preview section: The file will be added automatically to the list of items in the Project Media section of the screen
  4. Drag and drop the still picturer to the video track, double-click on the Loop Region, and finalize the length of time the picture should be shown
  5. File > "Render As": In the dialog, uncheck "Render loop region only".

Triming

To trim a video, eg. to remove the first part of a segment, first enable Ripple Editing through Options > Auto Ripple. Next, drag and drop it from the Project Media section into the Video track in the lower-half of the screen, then select the start and end points using the yellow triangles above the timeline, and finally choose Edit > Delete.

Q&A

How to jump to a given time in the video?

Double-click on the time at the lower right-hand side, and type the time.

How to fast-forward/rewind?

Use the J,K,L keys: L moves forward, K stops, J moves backward. Hitting the L/J multiple times increases the speed.

How to move frame by frame?

How to select video from start to current position, or from current position to end?

How to select start/end of a segment and delete?

Edit > Editing Tool = Envelope

Select section

Edit > Editing Tool = Normal

Edit > Delete

Why does audio slowly drifts during a video?

Noticed this when combining multiple 2GB files into a single project although all were shot during the same venue using the exact same camcorder.

Alternatives

Resources