Basic video editing with VSDC

Introduction

VSDC is a non-linear video editor by VideoSoft, free for personal use. A Pro version is also available.

Surprisingly, the free version lacks very basic features such as keyboard shortcuts to fastforward/rewind or ripple mode when removing a segment.

A user's manual as PDF in only available if you upgrade to the Pro version, but some articles are available on the site and videos are also available on Youtube (Activate the subtitles/closed captions for extra infos).

"object" can be a video file, audio file, image file.

To make layer line higher (easier to see), mouse-pull layer bottom line.

For some reason, as of 6.4.2.107, the "Cutting and splitting" is available both in the Editor section and the Export Project > Set markers.

Usage

How to change UI to light mode?

Options > Used style : Office 2016 White

Import media files

Editor > Add Object

OR

  1. View > Resources Window
  2. Drag and drop pictures to the Resources Window
  3. Drag and drop pictures from the Resources Window to the timeline. VSDC will create a new layer.

How to slice a video and only keep some parts?

One way to keep only some parts of a video track:

  1. Insert the video file onto a layer (video track)
  2. Click on the layer (If the Editor>Cutting and Splicing section is greyed out, no layer is currently selected)
  3. Set the cursor where the first wanted section starts
  4. CTRL+K to split (Sometimes, you need to click elsewhere in the interface before re-clicking on the video track)
  5. Select the first part (from start to current location)
  6. Delete
  7. Move the video to the beginning (the free version doesn't support auto ripple); You can also drag and drop a segment onto another layer
  8. Repeat.

www.videosoftdev.com/how-to-split-video-file

How to add slides in video overlay track?

Editor > Add objects > Apply Settings

How to keep VSDC from adding slides to timeline ? Work-around : Selected all but first pic, deleted them, moved first and only pic to right time.

How to import an audio track, and add slides in a video track?

Import objects into VSDC, and drag and drop them onto the timeline.

How to disable hardware acceleration when rendering output file with free version?

Options > Acceleration options, uncheck 'Use hardware acceleration for encoding video'

How to export a file?

Export Project > Choose format > Start Conversion.

How to reduce size of output file?

A 5mn, MP4, 720p HD file = 242MB!

How to change the default length of slides dropped onto timeline?

When drag and dropping picture from Resources Windows onto timeline, how to display for just a few seconds instead of till the end? In Options, "Default object duration" is set to 5s by default: Why till the end then? Double-click on object in timeline, and click back to Scene.

Suggestions

In Options > Applications Directories: Change dialog to allow pasting path so user doesn't have to waste time browsing through file directories.

Make upgrade easier to new free version

In YouTube, put the following videos at the top of the list:

By default, after importing a video, disable resizing: How many newbies need to do this?

Timeline doesn't move while dragging and dropping object left/right within the timeline.

Doesn't append object when adding it to a track in the timeline from the Resources Window: Instead, put on a new track.

Keeps adding new layer when moving object in Timeline up/down: No way to prevent this?

Q&A

When deleting a part in a video track, no automatic sliding to the left la Vegas?

What is a "sprite" ?

What's a scene?    

No way to jump to a given location in a video track?

What is the work area for?

How to use the "Cutting and splitting" window? Marker, region, selection

How to fastforward/rewind? ALT CTRL SHIFT arrows don't work

No other keyboard shortcuts? http://www.videosoftdev.com/news/audio-filteres-3d-charts

How to see splits better?

Resources